Antique Engines and Old Iron
[Home] - [HELP] - [Forums] - [Library] - [Photo Gallery] - [Groups] - [Classified Ads] - [Subscribe] - [Links] - [Books] - [Sponsors] -

Go Back   SmokStak > SmokStak® Support and Information > Smokstak Forums Meet and Greet
Forgot Password? Join Us!

Notices

Smokstak Forums Meet and Greet Welcoming Smokstakers New and Old, a place to say a bit about yourself and post a photo if you're really brave. If you have a technical question, please post it on one of our other boards.

Smokstak Forums Meet and Greet

Onan 4K Microquite KY series generator runs, stops, over speeds etc.


this thread has 0 replies and has been viewed 332 times

Reply
 
Thread Tools Display Modes
  #1  
Old 01-07-2017, 01:07:42 PM
WHallTN WHallTN is offline
Registered
 
Join Date: Jan 2017
Location: Knoxville, Tennessee
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default Onan 4K Microquite KY series generator runs, stops, over speeds etc.

For all the Onan gurues out there here's another mysterious quirk.

Generator sat idle for a year or so-wouldn't start. Drained main tank, purged lines with fresh fuel, got it to start but died. Removed carb, cleaned-ran rough, but ran, cleaned carb again. Replaced fuel filer and pump. seemed to run Ok for 5-30 minutes at a time then died. Wouldn't restart without manually manipulating choke-black smoke coming out of exhaust. Had to wait until it cooled completely before it started again. Ambient temp in the 50's. Again, would run for 5-20 minutes and then started to overspeed and shut down (code 14-overspeed condition sensed).

Backed off governor. Ran fine, put microwave and AC load on-ran great. Ran again later, microwave and AC load and when microwave timed out unit oversped again. Wouldn't restart until after cooling.

Ran it yesterday (temps below freezing) ran for 40 minutes until I shut it down.

I've read a ton of posts about this generator and am left with three things. First, fuel enrichment jet still not cleaned (although will sometimes run perfect for among period of time wth load/no load. Secondly, bad control panel affecting voltage regulator (although I get 125 volts consistently. Third, carberator itself is jacked up.

Troubleshooting:

-oil level checked and good
- fresh 100% gas with fuel treatment added
-voltage checked at AC outlet good-125 volts
-carb cleaned-three times
-fuel selonoind cleaned and works
-all wires checked for clean connection and grounded
-hooked up an external fuel cell to bypass entire fuel supply

While my intention is to run an external generator set (Honda EU1000 and EU 2000 parralled to provide longer running AC requirements) I'd still like the internal genset to work.

Only thing I can see changing is a new carb and/or control board. But that's not cheap.

Thoughts??
Reply With Quote
Sponsored Links
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

F o r u m Jump

Similar Threads Chosen at Random
Thread Thread Starter F o r u m Replies Last Post
Onan Bfa runs for 30 sec then stops dave2500 Onan Generators 6 02-03-2015 06:39:04 PM
Onan 4KY F series generator only runs if I hold the choke open bjhamlyn Onan Generators 12 12-23-2014 05:18:58 PM
Onan BGE Runs then Stops Snprdog Onan Generators 7 03-07-2011 05:16:24 PM
Onan Microquite 4000 smoking tipelc Onan Generators 2 02-17-2010 09:17:09 AM
Onan Microlite 4000 runs then stops sparkymarc Onan Generators 8 07-16-2009 10:10:15 PM


Use "Ctrl" mouse wheel to change screen size.
All times are GMT -4. The time now is 10:13:45 PM.

Smokstak and Enginads site search!


All use is subject to our TERMS OF SERVICE
SMOKSTAK® is a Registered Trade Mark - A Community of Antique Engine Enthusiasts
Copyright © 2000 - 2016 by Harry Matthews P.O. Box 5612 - Sarasota, FL 34277