Antique Engines and Old Iron
[Home] - [HELP] - [Forums] - [Groups] - [Classified Ads] - [Subscribe] - [Books] - [Sponsors] -

Go Back   SmokStak > SmokStak® General Discussion > Trucks, Trailers and Hauling for Shows
Forgot Password? Join Us!

Notices

Trucks, Trailers and Hauling for Shows The ins and outs of setting up a show trailer and getting it to and from the engine show. Please be fully aware of our web site Terms of Use Disclaimer as you read. Safety first!

Trucks, Trailers and Hauling for Shows

Got FI problems with my Chevy go getter


this thread has 38 replies and has been viewed 4699 times

Reply
 
Thread Tools Display Modes
  #1  
Old 08-05-2015, 01:45:16 PM
Avery22x36 Avery22x36 is offline
Registered
 
Join Date: Jun 2010
Location: Kansas
Posts: 723
Thanks: 439
Thanked 261 Times in 136 Posts
Default Got FI problems with my Chevy go getter

I got an old pickup I use for pulling a trailer around in weeds when I buy goodies, its been real dependable but old enough I never worry about dents and scratches. A month ago it started bucking and having trouble pulling a trailer, it has a 91 4.3 V6 in it and the parts guy told me to clean the TB so I did and put a new kit in. Started it up and it sounded great, hitting on all 6 but kept on revving up. I put a new throttle pos sensor on it and it still wrapped up, I put a new air sensor in it and did the same also. I unhooked everything on the throttle body but the wires going to the injector tips and it still did it. I am out of ideas, can't find a vacuum leak or anything obvious and it probably runs up to 3k if I let it. I didn't mess with anything else but the throttle body and got a couple hundred bucks in kit and sensors in it and worse now than when I started. Its like the fuel pump just forces the gas right on through? If anyone has an idea I would sure like to know because I am really needing it running. Thanks
Reply With Quote
Sponsored Links
  #2  
Old 08-05-2015, 03:06:59 PM
pegasuspinto pegasuspinto is offline
Registered
 
Join Date: Oct 2006
Location: Floyd, AR, USA
Posts: 2,985
Thanks: 319
Thanked 1,444 Times in 936 Posts
Default Re: Got FI problems with my Chevy go getter

Vaccum leak (anywhere on throttle body, plenum, intake, brake booster, vaccum accessories like A/C controls or front wheel drive selector.)

throttle body is being held open by misadjusted screw, dirt or damage to throttle body, throttle cable too tight or hanging up

idle air motor is stuck open (most likely IMHO)

Too much fuel just causes it to run rich, not faster. To run too fast it needs AIR.
Reply With Quote
The Following User Says Thank You to pegasuspinto For This Post:
  #3  
Old 08-05-2015, 03:36:22 PM
sdowney717 sdowney717 is offline
Registered
 
Join Date: Apr 2012
Location: Newport News, Virginia
Posts: 2,735
Thanks: 351
Thanked 1,440 Times in 755 Posts
Default Re: Got FI problems with my Chevy go getter

Quote:
it probably runs up to 3k if I let it. I didn't mess with anything else but the throttle body and got a couple hundred bucks in kit and sensors in it and worse now than when I started. Its like the fuel pump just forces the gas right on through? If anyone has an idea I would sure like to know because I am really needing it running. Thanks
Since the throttle is not moving and the engine is racing up in rpm's, it must be getting air and the Idle air control is the logical place to look for trouble.

You might consider going to a junker and getting an entire another TBI.
Lots of them will give you a 90 day warranty and it will be cheapest. If it does not work, take it back and they will refund you.
Reply With Quote
The Following User Says Thank You to sdowney717 For This Post:
  #4  
Old 08-05-2015, 07:42:06 PM
J.B. Castagnos J.B. Castagnos is offline
Registered
 
Join Date: Nov 2004
Location: South Louisiana USA
Posts: 2,738
Thanks: 931
Thanked 3,593 Times in 1,127 Posts
Default Re: Got FI problems with my Chevy go getter

Try to determine if the air is entering through the idle air passage, a port at the back of the throttle body. If so remove the idle air control and see if it's screwed way in, spring compressed, little of the shaft exposed. We have a tester that plugs in and controls the idle motor, you may be able to rent one at the auto parts, ours is a Thexton. If you can slow the motor down with this you can eliminate vacuum leaks and the idle motor, trouble is then likely in the computer or wires. Check the grounds at the thermostat housing.
Reply With Quote
The Following User Says Thank You to J.B. Castagnos For This Post:
  #5  
Old 08-06-2015, 09:13:02 AM
Avery22x36 Avery22x36 is offline
Registered
 
Join Date: Jun 2010
Location: Kansas
Posts: 723
Thanks: 439
Thanked 261 Times in 136 Posts
Default Re: Got FI problems with my Chevy go getter

Thanks everyone, I put a new Idle Air control on it and not luck, I am going back through the vacume and grounds. I am kind of discouraged right now, thanks
Reply With Quote
  #6  
Old 08-06-2015, 10:44:56 PM
J.B. Castagnos J.B. Castagnos is offline
Registered
 
Join Date: Nov 2004
Location: South Louisiana USA
Posts: 2,738
Thanks: 931
Thanked 3,593 Times in 1,127 Posts
Default Re: Got FI problems with my Chevy go getter

Was the idle motor pintle screwed in or was it extended? Did the idle increase as it ran? Did you check to see if the air was going in through the idle by pass port between the injectors in the back?
Reply With Quote
  #7  
Old 08-07-2015, 02:02:00 AM
Thaumaturge Thaumaturge is offline
Subscriber
 
Join Date: Mar 2014
Location: Beryl, Utah USA
Posts: 4,627
Thanks: 3,713
Thanked 4,909 Times in 2,053 Posts
Default Re: Got FI problems with my Chevy go getter

Sounds like a stuck injector to me. See if it runs with injector wire removed. Next thought is maybe a shorted drive transistor in the ECU. But an OBD reader ought to tell the problem.
Doc
__________________
'The time has come', the Walrus said,'To talk of many things: Of shoes and ships and sealing-wax Of cabbages and kings'
Reply With Quote
The Following User Says Thank You to Thaumaturge For This Post:
  #8  
Old 08-07-2015, 04:06:22 AM
Power Power is offline
Registered
 
Join Date: Aug 2011
Location: New Jersey
Posts: 5,451
Thanks: 1,259
Thanked 3,327 Times in 1,944 Posts
Default Re: Got FI problems with my Chevy go getter

Stop throwing parts at it!
Try this - cost is only time.
When you are sure there are no air leaks, and everything is properly installed, reset the computer. It is still working from old sensor values, and is confused.

To do this, disconnect the battery. Step on the brake pedal for a minute, or turn on the lights with the battery disconnected. Wait a good 15 minutes and reconnect battery.
Start it. Now computer has to relearn everything. If it is functioning, it should quickly regulate idle. It will run different for about 50 miles or an hour as it relearns.
Reply With Quote
The Following User Says Thank You to Power For This Post:
  #9  
Old 08-07-2015, 04:00:23 PM
Avery22x36 Avery22x36 is offline
Registered
 
Join Date: Jun 2010
Location: Kansas
Posts: 723
Thanks: 439
Thanked 261 Times in 136 Posts
Default Re: Got FI problems with my Chevy go getter

Well, it set over night with everything hooked up and the doors open so if there was any juice hid anyplace with the battery unhooked I assumed the dome light would have drained it?

---------- Post added at 02:52 PM ---------- Previous post was at 02:49 PM ----------

Quote:
Originally Posted by Thaumaturge View Post
Sounds like a stuck injector to me. See if it runs with injector wire removed. Next thought is maybe a shorted drive transistor in the ECU. But an OBD reader ought to tell the problem.
Doc
I pulled both sets of wires off and it would not run at all, I pulled only one set off and it would almost idle? I got a couple readers but not that go back this far, I would have to load it on a trailer and haul it an hour to find one, I live in the country.

---------- Post added at 03:00 PM ---------- Previous post was at 02:52 PM ----------

Quote:
Originally Posted by J.B. Castagnos View Post
Was the idle motor pintle screwed in or was it extended? Did the idle increase as it ran? Did you check to see if the air was going in through the idle by pass port between the injectors in the back?
I didn't know a lot about it but it looked like the new one I bought and had about as much travel when you pushed against it. The Carquest guy said I shouldn't have to mess with it if I just replaced it so I did. I am from the carb era, I am not that sharp at this, thanks
Reply With Quote
  #10  
Old 08-07-2015, 04:25:50 PM
David M. Lyon's Avatar
David M. Lyon David M. Lyon is offline
Registered
 
Join Date: Nov 2004
Location: Hattiesburg, Mississippi, USA
Posts: 3,213
Thanks: 518
Thanked 2,252 Times in 1,162 Posts
Default Re: Got FI problems with my Chevy go getter

The pintle of the idle control should be wiggled out of the solenoid enough so that it bottoms out against the seat when installed. Then the computer will automatically adjust the pintle out the proper number of steps to maintain the correct idle speed. If you pushed it in, the computer is lost because it uses the bottomed-out position as the base to know how many steps out to open the pintle. They were famous for getting out-of-whack back on the 90's models and had to be removed, bottomed-out, and then reinstalled.
Reply With Quote
The Following User Says Thank You to David M. Lyon For This Post:
  #11  
Old 08-07-2015, 08:45:33 PM
Dan A S Dan A S is offline
Registered
 
Join Date: Nov 2005
Location: Dundee, Ohio USA
Posts: 21
Thanks: 2
Thanked 9 Times in 9 Posts
Default Re: Got FI problems with my Chevy go getter

Hello those have a problem of carbon collecting in the EGR solenoid valve holding open making a vacuum leak and high idle f they stick open ll do whats happening noticeable at idle when it should be closed engine before reinstalling to blow out loose carbon they make a gasket with a screen to prevent future problems if it does it again
Reply With Quote
The Following User Says Thank You to Dan A S For This Post:
  #12  
Old 08-09-2015, 10:28:39 AM
Avery22x36 Avery22x36 is offline
Registered
 
Join Date: Jun 2010
Location: Kansas
Posts: 723
Thanks: 439
Thanked 261 Times in 136 Posts
Default Re: Got FI problems with my Chevy go getter

I am still working on it, Pintle seems to be in spec, the thing I don't get is when you start it and the butterfly is completely closed and stays so with the cable off, why is the tips putting out a huge amount of fuel? I am starting to wonder if it is a computer problem because it almost has to be electric to blow all that fuel through don't it? I am seriously thinking of making an adapter plate for a carb right now.
Reply With Quote
  #13  
Old 08-09-2015, 01:15:08 PM
Kevinp86 Kevinp86 is offline
Registered
 
Join Date: Jun 2014
Location: Chesterfield, Virginia, USA
Posts: 22
Thanks: 28
Thanked 13 Times in 5 Posts
Default Re: Got FI problems with my Chevy go getter

Under the dash board there is an obd1 connector with nothing plugged into it. there are 2 rows of terminals. on the top row on the right is terminal "a". terminal "b" is the second one in from the right. terminal diagram labeling is like this from left to right.
top row,"F", "E", "blank","C","B","A"
bottom row "G","H", "blank","blank","blank","blank"
take a small piece of wire and jump terminal "A" and "B". i found an unfolded paper clip works well. with the terminals jumped, turn the key to the on position.(DO NOT START ENGINE) with the key on, the service engine light will start flashing codes. count the flashes. it will repeat each code 3 times before moving on to the next code. your first and last code will be a code 12. that is just the test code. it lets you know you did it right. you will see 1 flash with a short pause then 2 flashes. after you see that 3 times, your next code will be your trouble codes. when you see code "12" again, there are no more. Once you have the code number you can look it up to see what it is. I can look them up for you monday once im back at work.

I would really be leaning towards a large vacuum leak or something you have done when rebuilding the throttle body considering this problem didn't exist until than maybe pull it back apart and double check everything you did and pay close attention to your gaskets making sure there right. Hope this helps! Kevin.
Reply With Quote
The Following User Says Thank You to Kevinp86 For This Post:
  #14  
Old 08-09-2015, 02:59:06 PM
David M. Lyon's Avatar
David M. Lyon David M. Lyon is offline
Registered
 
Join Date: Nov 2004
Location: Hattiesburg, Mississippi, USA
Posts: 3,213
Thanks: 518
Thanked 2,252 Times in 1,162 Posts
Default Re: Got FI problems with my Chevy go getter

A piece of carbon holding the EGR valve open slightly would cause that problem. I have also found where a backfire broke out a chunk of the EGR gasket and caused that. The computer is going to maintain a 14.7:1 fuel to air ratio. if it's getting a bunch of air it's going to dump in a bunch of fuel to maintain the correct stoichiometry.
Reply With Quote
The Following User Says Thank You to David M. Lyon For This Post:
  #15  
Old 08-09-2015, 03:18:37 PM
pegasuspinto pegasuspinto is offline
Registered
 
Join Date: Oct 2006
Location: Floyd, AR, USA
Posts: 2,985
Thanks: 319
Thanked 1,444 Times in 936 Posts
Default Re: Got FI problems with my Chevy go getter

Quote:
Originally Posted by Avery22x36 View Post
I am still working on it, Pintle seems to be in spec, the thing I don't get is when you start it and the butterfly is completely closed and stays so with the cable off, why is the tips putting out a huge amount of fuel? I am starting to wonder if it is a computer problem because it almost has to be electric to blow all that fuel through don't it? I am seriously thinking of making an adapter plate for a carb right now.
More fuel make it run rough and start to make black smoke out the pipe, NOT faster. HAS to be getting more air to burn that fuel, then it runs faster.

Having him flash the engine codes won't do much if there isn't a check engine light on. is it on? lol

Probably 95% of all computers in these cars are replaced have NO problem. That is the most reliable part of the whole system, honestly.
Reply With Quote
The Following User Says Thank You to pegasuspinto For This Post:
  #16  
Old 08-09-2015, 05:33:16 PM
Avery22x36 Avery22x36 is offline
Registered
 
Join Date: Jun 2010
Location: Kansas
Posts: 723
Thanks: 439
Thanked 261 Times in 136 Posts
Default Re: Got FI problems with my Chevy go getter

OK, this is what I did, I took the unit back off, made sure everything was right on it. I plugged the brake booster vacume line, I plugged all other lines on the TBI so the only air it could get was through the idle air motor and it is just barely under 1 1/8 out, both the new and old one. My assumption is that for some reason it is not getting the signal to close? It sounds good, reminds me of a big out engine when you stomp it and hear the air rushing in. I made a circle around the driveway, a fast one, I wouldn't do it if it had an auto, its that fast. Its frustrating because everything else is working good but the idle, I guess I will try to figure out the codes next. Thanks
Reply With Quote
  #17  
Old 08-10-2015, 12:11:55 PM
Avery22x36 Avery22x36 is offline
Registered
 
Join Date: Jun 2010
Location: Kansas
Posts: 723
Thanks: 439
Thanked 261 Times in 136 Posts
Default Re: Got FI problems with my Chevy go getter

I am about to go find a code reader, however, I unscrewed the air motor and had the key turned on while in my hand, it just kind of jumped and did not extend or retract it any noticable amount. With the TBI off and screwed in looking at the bottom, it lacks 3/16 of sealing so without moving out its not going to, I think that is my problem, now just why isn't it moving, or the other one moving, can't have two bad ones? I wouldn't think so anyway?
Reply With Quote
  #18  
Old 08-10-2015, 01:43:08 PM
Avery22x36 Avery22x36 is offline
Registered
 
Join Date: Jun 2010
Location: Kansas
Posts: 723
Thanks: 439
Thanked 261 Times in 136 Posts
Default Re: Got FI problems with my Chevy go getter

I got a code reader called "Auto X-Ray", I had to use a special cable to hook up, give the Vin number and all the usual and it ran a scan and said it was operating normal. Hmm. Now What?
Reply With Quote
  #19  
Old 08-10-2015, 03:11:43 PM
Doug Tallman Doug Tallman is online now
Subscriber
 
Join Date: Jul 2005
Location: Greenwich, Ohio, USA
Posts: 700
Thanks: 195
Thanked 370 Times in 269 Posts
Default Re: Got FI problems with my Chevy go getter

With A and b jumpered in the ALDL and the key on, you should get a bright-dim test light on 2 terminals of the IAC connector and the other two should be on-off. That is the test for the computer to be able to control it.
Reply With Quote
The Following User Says Thank You to Doug Tallman For This Post:
  #20  
Old 08-15-2015, 11:41:17 AM
Avery22x36 Avery22x36 is offline
Registered
 
Join Date: Jun 2010
Location: Kansas
Posts: 723
Thanks: 439
Thanked 261 Times in 136 Posts
Default Re: Got FI problems with my Chevy go getter

All the terminals are dim all the time, no matter if it is jumped or not? Thanks
Reply With Quote
Reply

Bookmarks


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

F o r u m Jump

Similar Threads Chosen at Random
Thread Thread Starter F o r u m Replies Last Post
Detroit 4-53/81 Chevy motormanjeff Antique Autos and Trucks 39 06-13-2016 01:19:50 AM
41 Chevy Pickup Tom Sampson Antique Autos and Trucks 25 05-18-2014 10:57:18 PM
Attn: To ALL chevy guys, Chevy parts N.O.S. & Repro parts Sky Antique Autos and Trucks 4 08-31-2007 11:47:33 PM


Use "Ctrl" mouse wheel to change screen size.
All times are GMT -4. The time now is 11:02:22 AM.

Smokstak and Enginads site search!


All use is subject to our TERMS OF SERVICE
SMOKSTAK® is a Registered Trade Mark - A Community of Antique Engine Enthusiasts
Copyright © 2000 - 2019 by Harry Matthews P.O. Box 5612 - Sarasota, FL 34277