Antique Engines and Old Iron
[Home] - [HELP] - [Forums] - [Library] - [Photo Gallery] - [Groups] - [Classified Ads] - [Subscribe] - [Links] - [Books] - [Sponsors] -

Go Back   SmokStak > SmokStak® Vintage Electrical Equipment > Generators & Electric Motors General Discussion > Military MEP and Aircraft Gen-Sets
Forgot Password? Join Us!

Notices

Military MEP and Aircraft Gen-Sets MEP Mobile Electric Power, APU Auxiliary Power Unit and other military surplus generators.

Military MEP and Aircraft Gen-Sets

MEP-003A. Runs rough


this thread has 7 replies and has been viewed 569 times

Reply
 
Thread Tools Display Modes
  #1  
Old 10-14-2018, 05:24:00 PM
Onan Onan is offline
Registered-II
 
Join Date: Aug 2010
Location: Pickens SC
Posts: 99
Thanks: 2
Thanked 6 Times in 5 Posts
Default MEP-003A. Runs rough

I have a low hours mep-003a that is only running on a couple of cylinders. The last time I ran it, about three months ago, it ran fine. Now when i try to run it, it runs very rough and does not come up to speed and smokes alot. Do I have an injector pump problem, or perhaps a filter or some thing else. Does running the unit at lower speed have any dangerous effect on the gen elect.system?
Any suggestions would be very much appreciated.
Thanks
Jerry
Reply With Quote
Sponsored Links
  #2  
Old 10-14-2018, 09:20:04 PM
dependable dependable is offline
Registered-II
 
Join Date: Jan 2013
Location: Massachusetts, USA
Posts: 678
Thanks: 114
Thanked 218 Times in 155 Posts
Default Re: MEP-003A. Runs rough

Might be old fuel, a little water in fuel, if you have not serviced filters and water separator lately, I'd check that first before wondering about anything else.
Reply With Quote
  #3  
Old 10-15-2018, 09:18:04 AM
kwfiggatt kwfiggatt is offline
Registered-I
 
Join Date: Jan 2012
Location: Charleston, West Virginia
Posts: 161
Thanks: 35
Thanked 57 Times in 43 Posts
Default Re: MEP-003A. Runs rough

Running the set at less than 1800 can fry the voltage regulator board - don't do it. I have an mep002a, and it gets started with the throttle set at 1800.

As for your rough running problem, I'd check the injectors. One that is stuck open (or closed) could cause the issues you are talking about. Also check fuel filters and the electric pumps on this set (there are three total - one is used for the external refueling system and two that feed the IP - one is redundant). Also, the pumps have screens in the bottom that probably need cleaned.

In case you haven't found it yet, steel soldiers is a great source of info for the military equipment. steel soldiers

Hope this helps...

Kevin
Reply With Quote
  #4  
Old 10-15-2018, 05:17:03 PM
Onan Onan is offline
Registered-II
 
Join Date: Aug 2010
Location: Pickens SC
Posts: 99
Thanks: 2
Thanked 6 Times in 5 Posts
Default Re: MEP-003A. Runs rough

Thanks for suggestions for a fix. The fuel and fuel delivery systems are fine. Today as I tried to run the unit, I pushed up on the throttle linkage near the injector pump and the engine appeared to come up to speed. What is that a sign of? I am concerned about running the unit at a reduced speed trying things for fear of harming the electronics.
All sugestions appreciated.
Thanks
Reply With Quote
  #5  
Old 10-15-2018, 09:19:56 PM
dependable dependable is offline
Registered-II
 
Join Date: Jan 2013
Location: Massachusetts, USA
Posts: 678
Thanks: 114
Thanked 218 Times in 155 Posts
Default Re: MEP-003A. Runs rough

Lube up the linkage and move it some. Get a Killowatt and plug it into convenience outlet and adjust throttle to 60 Hz, if the hertz gauge is still working, great. A lot of times the are not, and Hz reading will help you set correct RPM.

Suggest you get the manuals available free from the site kwfiggatt linked. These are great machines, but they are not plug and play. Most have been sitting for a while and need some basic maintenance.
Reply With Quote
  #6  
Old 10-17-2018, 09:18:22 PM
Onan Onan is offline
Registered-II
 
Join Date: Aug 2010
Location: Pickens SC
Posts: 99
Thanks: 2
Thanked 6 Times in 5 Posts
Default Re: MEP-003A. Runs rough

Thanks for all suggestions. I believe that I have a broken governor that is not allowing the engine to come up to speed.
I have manuals TM5 6115- 585-12 and TM5-6115-585-34. Servicing the governor looks to be a very involved procedure. Is any one familiar with servicing, repairing this governor. Is there a history with this governor failing? Is there a test I can perform to confirm that the governor is the problem?
Thanks for looking
Thanks
Onan
Reply With Quote
  #7  
Old 10-18-2018, 10:15:23 PM
David C David C is offline
Registered-III
 
Join Date: Mar 2006
Location: Lake Jackson,Texas
Posts: 1,415
Thanks: 1,120
Thanked 906 Times in 581 Posts
Default Re: MEP-003A. Runs rough

The governor system on the J/DJ series engines are a robust design and I have not heard of many failures. I would make sure the governor spring did not break. Does the engine run on all 4 cylinders when you manually speed up the genset. What is the frequency meter show when it is running rough?

David C.
Reply With Quote
  #8  
Old 11-15-2018, 08:36:30 PM
toms toms is offline
Registered-I
 
Join Date: May 2012
Location: Carencro, Louisiana
Posts: 41
Thanks: 0
Thanked 4 Times in 4 Posts
Default Re: MEP-003A. Runs rough

I have both mep 003 and the 002. If all other checks fail, it's likely the injection pump. I have had the same problem with both sets and solved the problem with changing the pump.
Reply With Quote
Reply

Bookmarks


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

F o r u m Jump

Similar Threads Chosen at Random
Thread Thread Starter F o r u m Replies Last Post
Runs Rough at Half Choke HistoryBuff Carburetors, Mixers, Fuel Pumps and fuel delivery 8 09-23-2016 06:50:38 PM
1976 3.5HP mower runs rough ssnjimb Garden Tractors / Mowers / Scooters 3 08-24-2016 02:10:21 PM
MEP 003A no power engine starts and runs good. Ed ke6bnl Military MEP and Aircraft Gen-Sets 8 12-21-2015 04:44:13 PM
Maytag model 82 runs rough macie1mike Maytag Engine Collectibles 8 05-03-2012 11:16:02 AM
Kohler 14RESL runs rough RJ1996 Kohler Generators 4 03-03-2012 10:58:57 AM


Use "Ctrl" mouse wheel to change screen size.
All times are GMT -4. The time now is 08:01:23 AM.

Smokstak and Enginads site search!


All use is subject to our TERMS OF SERVICE
SMOKSTAK® is a Registered Trade Mark - A Community of Antique Engine Enthusiasts
Copyright © 2000 - 2016 by Harry Matthews P.O. Box 5612 - Sarasota, FL 34277