Generators and Motors
[Home] - [HELP] - [Forums] - [Library] - [Photo Gallery] - [Groups] - [Classified Ads] - [Subscribe] - [Links] - [Books] - [Sponsors] -

Go Back   SmokStak > SmokStak® Vintage Electrical Equipment > Generators & Motors General Discussion > Onan Generators
Forgot Password? Join Us!

Notices

Onan Generators Restoring, operating and maintaining vintage Onan generators.

Onan Generators

Onan 4.0 BFA troubleshoot advice?


this thread has 7 replies and has been viewed 200 times

Reply
 
Thread Tools Display Modes
  #1  
Old 04-11-2017, 10:43:15 AM
thoml thoml is offline
Registered
 
Join Date: Apr 2017
Location: Wayzata, Minnesota, USA
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Onan 4.0 BFA troubleshoot advice?

Have a 1986 Onan 4.0 BFA 1R/16020C #F863117686E genset. Past years, always start/run.
Tried firing it up this year, got clicking solenoid sound, so checked battery and cleaned connections.

Still just clicking. I replaced the K-1 solenoid, now when I connect the + battery cable to the solenoid, it slowly clicks constantly, immediately after hooking it up, without engaging the start
switch at all.


Was hoping someone might recognize what this might be, I appreciate any insights.
Reply With Quote
Sponsored Links
  #2  
Old 04-11-2017, 10:53:52 AM
JohnnyC JohnnyC is offline
Subscriber
 
Join Date: Jun 2014
Location: Boonton, New Jersey
Posts: 3,219
Thanks: 749
Thanked 1,356 Times in 826 Posts
Default Re: Onan 4.0 BFA troubleshoot advice?

Me thinks bad solenoid. This assumes all electrical connections are clean and secure including a good ground.

JohnnyC
New Jersey
Reply With Quote
  #3  
Old 04-11-2017, 11:05:51 AM
nothingbutdarts nothingbutdarts is offline
Sponsor
 
Join Date: Apr 2014
Location: Bailey, Colorado, USA
Posts: 1,731
Thanks: 3,801
Thanked 672 Times in 477 Posts
Default Re: Onan 4.0 BFA troubleshoot advice?

Where did you buy the K-1 solenoid??? There are a lot of different type of solenoids out there.
Reply With Quote
  #4  
Old 04-11-2017, 11:22:08 AM
Vanman Vanman is offline
Subscriber
 
Join Date: Aug 2011
Location: Mission Viejo, California
Posts: 2,598
Thanks: 3,019
Thanked 1,021 Times in 717 Posts
Default Re: Onan 4.0 BFA troubleshoot advice?

What is the terminal voltage of the battery while it's trying to crank?
Reply With Quote
  #5  
Old 04-11-2017, 11:28:56 AM
thoml thoml is offline
Registered
 
Join Date: Apr 2017
Location: Wayzata, Minnesota, USA
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Onan 4.0 BFA troubleshoot advice?

I just bought a generic solenoid - Carquest BWD S63P - sounds like that was a mistake.... since it looked the same with same "s" and 'i" primary terminals as the Onan 307-1617 I assumed it compatible.
Reply With Quote
  #6  
Old 04-11-2017, 01:06:55 PM
thoml thoml is offline
Registered
 
Join Date: Apr 2017
Location: Wayzata, Minnesota, USA
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Onan 4.0 BFA troubleshoot advice?

I just bought a generic solenoid - Carquest BWD S63P since it looked the same with same S and I primary terminals as the Onan 307-1617, I assumed it compatible.
Reply With Quote
  #7  
Old 04-11-2017, 01:09:26 PM
Billy J Shafer's Avatar
Billy J Shafer Billy J Shafer is offline
Subscriber
 
Join Date: Nov 2004
Location: Centerville, Texas
Posts: 15,494
Thanks: 7,847
Thanked 12,714 Times in 5,986 Posts
Default Re: Onan 4.0 BFA troubleshoot advice?

Wrong solenoid.
__________________
I don't talk to myself. This early in the morning. Why the hell should I talk to you.
Reply With Quote
The Following User Says Thank You to Billy J Shafer For This Post:
  #8  
Old 04-11-2017, 11:42:01 PM
lokay5's Avatar
lokay5 lokay5 is offline
Subscriber
 
Join Date: May 2007
Location: Merlin, Oregon
Posts: 1,252
Thanks: 3,232
Thanked 730 Times in 459 Posts
Default Re: Onan 4.0 BFA troubleshoot advice?

Quote:
Originally Posted by thoml View Post
Have a 1986 Onan 4.0 BFA 1R/16020C #F863117686E genset. Past years, always start/run.
Tried firing it up this year, got clicking solenoid sound, so checked battery and cleaned connections.

Still just clicking. I replaced the K-1 solenoid, now when I connect the + battery cable to the solenoid, it slowly clicks constantly, immediately after hooking it up, without engaging the start
switch at all.


Was hoping someone might recognize what this might be, I appreciate any insights.
This info may help you-

https://www.smokstak.com/forum/showt...noid+size+fits
__________________
1973 CK5 Blazer
Reply With Quote
The Following User Says Thank You to lokay5 For This Post:
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

F o r u m Jump

Similar Threads Chosen at Random
Thread Thread Starter F o r u m Replies Last Post
Onan Marine 6.5 MCCK Spec J- Trying to troubleshoot. SpudPlucker Onan Generators 9 08-22-2013 08:10:16 AM
Please help me troubleshoot an Onan engine 69zfarmer Onan Generators 13 11-28-2011 08:38:37 AM
Lincoln SA 200 troubleshoot help? 123weld Welding Shop 1 07-10-2008 07:20:57 AM
won't run right...troubleshoot Jeb Lloyd Antique Engine Archives 6 05-27-2004 12:00:54 PM
Kohler Troubleshoot Smoke Antique Engine Archives 2 06-04-2003 07:32:14 AM


Use "Ctrl" mouse wheel to change screen size.
All times are GMT -4. The time now is 03:35:45 AM.

Smokstak and Enginads site search!


All use is subject to our TERMS OF SERVICE
SMOKSTAK® is a Registered Trade Mark - A Community of Antique Engine Enthusiasts
Copyright © 2000 - 2016 by Harry Matthews P.O. Box 5612 - Sarasota, FL 34277