Generators and Electric Motors
[Home] - [HELP] - [Forums] - [Groups] - [Classified Ads] - [Subscribe] - [Books] - [Sponsors] -

Go Back   SmokStak > SmokStak® Vintage Electrical Equipment > Onan Generators
Forgot Password? Join Us!

Notices

Onan Generators Restoring, operating and maintaining vintage Onan generators. When asking new questions about your generator, ALWAYS give your model number AND serial number.

Onan Generators

Onan in RV shows error code 11


this thread has 5 replies and has been viewed 1524 times

Reply
 
Thread Tools Display Modes
  #1  
Old 06-30-2016, 09:18:21 PM
Kingfish Kingfish is offline
Registered
 
Join Date: Jun 2010
Location: Albemarle, North Carolina
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Onan in RV shows error code 11

I know this is not an RV group but I need help troubleshooting this problem.
Thanks.

RV: 2000 Bounder 39z
Generator: Onan Model 7.5HDKAJ11502F
Serial No. J990999200
Inverter/Charger: Freedom 458 Model 20D (with remote control panel)
Panel Box: PowerTek PDC1020


Background: Generator has always worked perfectly and exercised on a fairly regular basis. Returning home from a trip in the Spring, we ran the generator for 3 hours or so to power the AC, as we normally do in warm weather. Everything worked fine. A couple months passed before another trip was planned and when the generator was tested, it ran a few seconds and died.


Troubleshooting:
(1) The generator will crank and run fine when the breaker on the generator is OFF. If this breaker is ON, the generator will run until the transfer relays kick in, then it immediately dies. The error code is 11, Overcurrent Fault.
(2) My memory is a little fuzzy on this. While preparing for that second trip, the RV was hooked to my 30 amp pedestal. (this pedestal is wired correctly and uses a Progressive EMS-PT30C in line) The RV was hooked up for several days and at least twice, the Freedom 458 gave a "overtemp/overload" red light warning. The PT30C did not give any indication of a problem. After disconnecting and reconnecting the shore power the Freedom 458 seemed to work OK, with no more red light. BUT, I did smell a "faint" smell of hot plastic. No fuses were blown and the smell did not continue. During our second camping trip, the Freedom 458 worked OK.
(2a) This may be unrelated. In an outside bay, I have a Power Guard PG30 push-button breaker. Several times on this camping trip, this breaker would pop, killing AC power to the RV. A simple single-push would reset the breaker and restore power. This happened several times but when it happened, there were no problems indicated on the Progressive PT30C. When we returned, I replaced the breaker.
(3) This week, I decided it was time to fine the problem. I removed the cover from the PowerTek and I find two wires that have melted insulation. These Black and White wires are #10 stranded. One end attached to the two movable contacts on the right hand relay. The other ends attach to a Romex cable that exits the PowerTek box.
(4) The first thing I tried was cutting out the bad sections and making new connections. Cranking the generator resulted in the same problem. Next, I tried breaking the connection, capping off each wire end to take it out of the circuit, then cranking the generator. Same problem, it died.
(5) One thing that I have not done since repairing the burned wires. I have not hooked the RV to shore power to see if there is new melting.


At this point, I don't know how to progress. I have a Fleetwood electrical wiring diagram but it is the most impossible schematic I've ever tried to understand. If anyone has suggestions, I sure can use some help. Maybe someone has had this same problem? Direct replies can be sent to onanproblem at objectmail dot com.


Thanks,
Ed
Reply With Quote
Sponsored Links
  #2  
Old 06-30-2016, 09:57:06 PM
Billy J Shafer's Avatar
Billy J Shafer Billy J Shafer is offline
Moderator
 
Join Date: Nov 2004
Location: Centerville, Texas
Posts: 18,917
Thanks: 9,996
Thanked 16,795 Times in 7,770 Posts
Default Re: Onan in RV shows error code 11

Not an RV group but we are a generator group. I would go back to the generator. Turn off the breakers at it. See if it runs ok. If it does then you need to check the wiring to where it hooks up to the RV. And your systems in the RV.


Iam old and need to clean my glasses. Forget the breaker check. Since you already have. But yes you need to check all circuits. I would start at the main breaker box. Check for loose connections and faulty breakers. I would try turning off all breakers. Then plug up to shore power. Have some one standing by to pull the plug. Turn on each breaker. See if anything trips or smells like melting wires. Not the best way to do a test. But the only other way would be to rip up the RV.
__________________
I don't talk to myself. This early in the morning. Why the hell should I talk to you.

Last edited by Billy J Shafer; 07-01-2016 at 10:13:50 AM.
Reply With Quote
The Following User Says Thank You to Billy J Shafer For This Post:
  #3  
Old 07-01-2016, 06:16:51 AM
Gunny Gunny is offline
Subscriber
 
Join Date: Feb 2005
Location: North Carolina
Posts: 3,835
Thanks: 1,856
Thanked 1,717 Times in 1,074 Posts
Default Re: Onan in RV shows error code 11

Sounds to me like you have a problem with something in the RV wiring or electronics. Genset appears to be operating like it should.
Reply With Quote
The Following User Says Thank You to Gunny For This Post:
  #4  
Old 07-01-2016, 12:09:21 PM
len k len k is offline
Subscriber
 
Join Date: Jun 2012
Location: Manchester, New Hampshire
Posts: 19,163
Thanks: 662
Thanked 7,357 Times in 5,230 Posts
Default Re: Onan in RV shows error code 11

Maybe mouse damage on RV wiring???

Or A/C pump is short cycling??

With melted insulation on 10 gauge and melted plastic smell you the problem is real. I'ld say you definitely have a over load somewhere, or at least a bad connection. Need to find it before it burns up on you.

I don't know RVs but from web the Progressive EMS-PT30C does not appear to be a breaker or current sensor, so not surprising that it did not report any overload.

Last edited by len k; 07-01-2016 at 12:33:59 PM.
Reply With Quote
  #5  
Old 07-26-2016, 12:36:51 PM
Gary Potts Gary Potts is offline
Registered
 
Join Date: Oct 2008
Location: Ridgecrest, Calif. Ours
Posts: 33
Thanks: 0
Thanked 14 Times in 9 Posts
Default Re: Onan in RV shows error code 11

You need an inverter.
Reply With Quote
  #6  
Old 07-29-2016, 11:33:43 AM
hlflorek hlflorek is offline
Registered
 
Join Date: Mar 2010
Location: Elizabethtown, Kentucky
Posts: 108
Thanks: 8
Thanked 25 Times in 14 Posts
Default Re: Onan in RV shows error code 11

Are you positive it is a code 11, and not a code 1? Huge difference, and most people have a hard time telling them apart.
Reply With Quote
Reply

Bookmarks


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

F o r u m Jump

Similar Threads Chosen at Random
Thread Thread Starter F o r u m Replies Last Post
Onan Microquiet 4000 Error code 32 Brett021 Onan Generators 16 07-30-2018 09:01:30 PM
Onan 5500 Generator Error Code 58 southernloco Onan Generators 48 02-09-2018 02:04:43 PM
Onan 7MDKBL-5871F error code 2 Spiv Onan Generators 3 11-14-2016 04:28:31 AM
Onan 7HGJAE type B, error 3 code 15 sdetweil Onan Generators 0 09-03-2013 06:07:16 PM
Onan 200DSHAC-6728 Spec: C / Error Code 235 LOW COOLANT LEVEL SupermanSC Onan Generators 10 12-02-2011 09:35:01 AM


Use "Ctrl" mouse wheel to change screen size.
All times are GMT -4. The time now is 05:40:25 AM.

Smokstak and Enginads site search!


All use is subject to our TERMS OF SERVICE
SMOKSTAK® is a Registered Trade Mark - A Community of Antique Engine Enthusiasts
Copyright © 2000 - 2019 by Harry Matthews P.O. Box 5612 - Sarasota, FL 34277