Airco Wasp welder with Onan CCKA Engine

Colin O

Member
I recently acquired an Airco Wasp welder / generator.
It is AC 225 DC 200 amp on the welding side at 3000 rpm and a 5 KW generator at 1800 rpm. It seems to basically be a Miller AEAD welder / generator built for Airco.
It runs , generates and welds excellent but I get a touch of white smoke out of one piston at idle. At full rpm no smoke. Compression on both cylinders is about 130 psi. I was wondering if this could be a carb adjustment issue, valve issue, or something else. Doesn't seem like it could be burning oil if the compression is so high. I have only ran it for about 30 minutes in total. Any thoughts?

Colin o
 

Attachments

YellowLister

Subscriber
Made 3 of 78... white smoke is oil.. did it sit for a long time before you got it? Could be carbon buildup as well.

Looks very clean. The smoke can be from rings not seated or stuck allowing oil to pass.. or valve seat may have small scoring allowing oil to pass into the cylinder.

I would run the generator part under a good load for a hour or so and see if it clears up... or if you really want to find the issue pull the heads and see if there is any scoring or carbon buildup
 

Colin O

Member
Thanks for the reply yellow Lister. The guy I got it from said it had not been started in 4 years.
Will try running it for a while and see how if it clears up.

Colin o
 

slip knot

Subscriber
Those are cool little machines. I have a yellow airco wasp and the miller AEAD. both are pretty capable machines.

I agree on running it. Rings may be stuck.
 

Billy J Shafer

Moderator
Your main problem. It hasn't run in 4 years. I can't tell you how many times I have heard. It has not been run in years. Because we are saving it.Then they get a large repair bill. Because they are saving it.
 
Top