• If you like antique engines, vintage tractors or old iron machinery, register and join us. When you register on Smokstak, please give complete answers and fill in the blanks. - IF YOU ARE ON WIRELESS OR SATELLITE, ENTER YOUR CITY AND STATE! NO ZIPCODES! All registrations are manually approved.

Kohler 30RES UU issues

Hellrider

Registered
Generator originally had issues faulting on under voltage intermittently. Discovered that the rotor bearing had seized, and spun in the end frame housing. As a result, the SCR module had also failed due to brushes jumping up and down on the slip rings.
Replaced the bearing, frame , and SCR module.
Unit starts and loads up, but every couple of starts it faults on UU still.
Performed separate excitation test- nothing is showing faulty.
Now, I have noticed that the flash relay flickering before the unit shuts down. Voltage signal to the RIB is fluctuating during these events as well.
Now for the question- how do I isolate the control board, or the RIB as the fault?
Could the control board be responding due to poor speed signal?
How do I isolate this?

TIA
 

Birken Vogt

Email NOT Working
IIRC, the controller grounds wire FL which completes the circuit on the flash relay. The high side of the flash relay coil is hooked to +12VDC. So wire FL has +12vdc on it when inactive and 0vdc on it when active. During active time the slip rings will be receiving battery voltage across them.

I had one do something like this a few years back. The problem was the relay on the relay board. New board, problem solved. Except when the owner tried to start it while connected to load. It would not come up to voltage when it was connected to an external load.
 

Hellrider

Registered
so the relay is basically allowing battery voltage to the rings as initial excitation till system voltage builds, and is activated by the adc 2100 grounding FL from the RIB?
 

Birken Vogt

Email NOT Working
Correct,

1. the LED is in parallel with the relay coil, so it shows when it should be active

2. the relay is double pole so it switches both ground and hot to the field winding, and leaves them float when not activated

3. the control board has its own funny flash pattern, even in normal operation, you will see it blink a couple times, and it happens real fast.
 

Hellrider

Registered
Ok, so start with new relay board and go from there.
I guess I could prove it, by cutting FL and grounding externally and checking for inconsistent operation?
Tough system to troubleshoot, with out parts swapping, being that there is some form of feedback loop between each component
 

Birken Vogt

Email NOT Working
I don't remember how I troubleshot the one I had trouble with, other than thinking it was not so hard to figure. I believe the relay board has power at all times so you can just remove FL from the controller and ground it without anything running. See if the relay works every time. Also remember the relay switches both power and ground at the same time so be checking both.
 

Hellrider

Registered
Birken Vogt, thanks for the advice. I will be returning to complete the repair later this week, and I will let you know how I make out.

Thanks !
 
Top