• Join us and fill out the registration form with your INTERESTS, your CITY, STATE, COUNTRY, NO ZIP CODES! Your account is then manually checked and approved. Please follow these instructions by using City, State, Country in your location! Incomplete applications will be REJECTED. If you like what you see here, PLEASE SUBSCRIBE and support our web site! -- Harry

Onan Microlite 2800, Spec. G fails to stay running

jtm198

Registered
Model No: 2.8 KV-FA/26100G

S/N: F980763392

I bought a 1998 Roadtrek Versatile 200 (Chevy Express 3500 / 5.7L) with an Onan 2800 Microlite mounted underneath in 2011.

The genset always started rough and took a while to generate AC voltage but once running ran like a champ.

Last summer when the van's built in air conditioning compressor failed I ran the genset for hours during vacation.

This year the remote start feature stopped working. I sprayed carb cleaner and was able to start it locally.

The remote start switch seems to check out, suspected open circuit somewhere.

I attempted to removed the gen set but stopped when it came to remove AC lines and fuel line.

I reinstalled. It failed to crank yet I could hear the fuel pump running. Suspected un-primed fuel line.

I removed it a few weeks later and performed the following:

Changed air filter, fuel filter, spark plug, disassembled/cleaned/reassembled carburetor.

Removed low oil level switch and cleaned oil pan.

Re-painted the mounting tray and replaced rusted out hardware.

Testing it on the bench it cranks, starts and fails to run.

I believe I have all the up to date manuals.

I have a couple of questions.

Should I simply replace the carb or try to clean it again? My dad helped me clean it and put it back together yet I told him that it was meant to be replaced (Spec. G).

How do I setup a test configuration? I have been using a John Deer tractor to jumper 12Vdc and as a fuel source but without the muffler hooked up or a sizable ground.

The mounting is underneath the van so this would make repeated install/removals tedious.

I have also downloaded the "Flight Systems" Troubleshooting Guide yet haven't made it all the way through their steps.
 
Going to assume that you mean it starts and runs but stops as soon as you let go the start switch.

If that is correct, 2 things will cause it to do that. First and most likely is that its not making power. Second and least likely is the oil level switch. That enge is splash lubricated so no pressure.
 
......Testing it on the bench it cranks, starts and fails to run.....

.....Should I simply replace the carb or try to clean it again? My dad helped me clean it and put it back together yet I told him that it was meant to be replaced (Spec. G)......

IF engine fires and runs fine while start button is held that tells me carb is working and problem is elseware.

Common to clean and adjust a carb. Not playing with it and spending $$$$$$$$ for a new one is an EPA pollution idea so people don't adjust it to something other than what they want :bonk:

Think that one shuts down the engine after you release start button if it's not making AC. Check for AC while it does run.

Also good to unplug remote switch at the gen , this will prevent any RV wiring problems from effecting gen. If remote's stop wire is shorted to ground that may tell engine to stop.

If it's not making AC , I'ld first check rotor resistance , specs are in manual and insulation resistance to frame. If that checks out there is a 2-nd test where you, unplug voltage reg, run gen, apply 12VDC across the rotor brushes and measure voltages off the stator. If all that's good it's likely a dead reg.

Do you have the service manual ?
 
Last edited:
Thanks guys,

My post was long.

I completely removed the low oil level switch (and threw it out) when I cleaned the oil pan.

Sounds like I have to check the generator and get back to you guys.
 
With oil level switch removed just make sure wire that used to go to it is insulated from ground/frame.
Anytime it grounds spark for spark plug stops.

service manual number and link to it
microlite--KV--SERVICE--(begins C )--(11-04)---981-0518E
http://www.twinslan.net/~n0nas/manuals/onan/
 
These sets are famous for failed controllers. On 90% of them that do this, if you beat on the controller/regulator, the set will now work. They develop internal failed solder joints.

Also, lack of AC output from the gen end from an internal failure will cause this. The controller looks for AC and will keep the set running when you release the start switch if AC is present. No AC, no run.
 
I ran the set a few weeks ago (just got back from vacation).

When it started up, I thought it was going to take off. Maybe I was suprised how loud they are with the cover off from one foot away.

Anyway, I released the start switch and it kept running. Could not get an AC voltage, AC breaker was shut.

Pressed the stop switch and kept running. Pulled the spark plug to stop ignition.

I will try to run it tomorrow and have my dad look at it.
 
i would have kept the low oil float switch unless it was broken, if it was i would have replaced it, failure prone or not
 
I agree, I should have simply disconnected and taped the wire. Will re-install a brand new one once I get it running again.
 
On a separate note, does anyone have any advice regarding removing the plastic scroll assembly without damaging it? I tried this once to inspect the brushes and slip rings and backed off for fear of damaging it.
 
you might need to sit down for a while after seeing the price of the low oil float switch.
 
Anyway.....

Replaced carburetor, voltage regulator and cleaned slip rings.

Machine starts and runs fine.

Any tips on how to setup the speed & speed sensitivity setting.

I'm not sure if my Craftsman clamp on ammeter has good frequency error or not because the unit dipped down to ~ 50 Hz when I tried to apply over 2000 W on this machine.

Any help with fine tuning a Microlite 2800 would be appreciated. It does not surge anymore like it did with the old carburetor.
 
Here are pictures for reference, yesterday it started backfiring and surging. I suspect gasoline in the oil (SAE 30). I will change with 5W30 before testing again.
 

Attachments

  • IMG_20161009_102019306.jpg
    IMG_20161009_102019306.jpg
    53.5 KB · Views: 135
  • IMG_20161009_102039471.jpg
    IMG_20161009_102039471.jpg
    44.6 KB · Views: 132
  • IMG_20161009_102043947.jpg
    IMG_20161009_102043947.jpg
    58.7 KB · Views: 130
  • IMG_20161009_102055219.jpg
    IMG_20161009_102055219.jpg
    47.7 KB · Views: 123
Well its a new year and of course new problems.

Installed a new air conditioner in my Roadtrek. Fired up the generator and the A/C ran on the Onan for about 3-5 minutes before I lost A/C. Genset kept running unloaded for a while before I shut it down.

Today I tested it and it runs around 50 48 - 50 Hz (3000 rpm) and puts out 100V AC.

I suspect the governor mechanism should be replaced. The speed screw setting is backed off almost all the way (CCW). Any other thoughts/guidance?
 
Suggest you get the manual for this machine and adjust as per directions. It should be running at 61.5 Hz at no load, that is directly relative to the output voltage which should be right at 120 VAC plus or minus a few. 100 VAC is way too low and wil result in damage to your new ac.
 
I have the manual. Doesn't really help. I adjusted the "no load speed setting" in both directions stays at that speed/frequency. During my last trouble shooting session, the leads were lifted that go to the transfer switch to not damage any electrical equipment. I guess I am looking for confirmation that it is the generator mechanism. I could not find anything online to replace the governor gearing, unless you guys know of a "like" replacement. The machine is in difficult spot and I can not change spring settings etc easily.

Also, the governor springs were replaced and positioned in the correct holes per the service manual. I had to adjust the governor arm per the service manual. I don't remember how much travel there was full open to full close.
 
There are three governor adjustments:

The Idle Stop adjustment sets minimum engine speed.
The Governor Sensitivity adjustment controls how quickly the governor responds to load changes
The Governor Speed adjustment sets the engine speed.

Your Governor Sensitivity adjustment looks good as is, about in the middle of it's range. Do not change it.

Back the Idle Stop screw almost all the way out. Start the generator and let it warm up. Turn the Governor Speed adjustment clockwise to increase tension on the governor spring and increase engine speed. Set this adjustment for approximately 61Hz. When the engine speed is correct, with no load on the generator, slowly turn the idle stop screw clockwise until the engine speed starts to increase, then back it off a bit.
 

Attachments

  • Governor adjustments.jpg
    Governor adjustments.jpg
    50.9 KB · Views: 95
  • Idle Stop Adjust.jpg
    Idle Stop Adjust.jpg
    44.9 KB · Views: 85
Sometimes the governor arm slips on the governor shaft, due to insufficient clamping force. If the OP has no governor control, this could be the issue. zuhnc
 
Thanks, I never adjusted the idle speed setting on the new carb after installing. Its probably all the way in.
 
Back
Top