• If you like antique engines, vintage tractors or old iron machinery, register and join us. When you register on Smokstak, please give complete answers and fill in all blanks. IF YOU ARE ON WIRELESS, GIVE YOUR CITY AND STATE! NO ZIPCODES! We get hundreds of applications, so there is no time to deal with missing information.

Wisconsin AEN on a Howard Rotovator

transman05

Registered
I am repairing a late 50s Howard Gem and need a piece for the AEN that is bolted up to it. This was an import from the UK, and it is my understanding that these units were shipped engineless to the states and then the dealer would power it, most likely with these Wisconsin engines.
Those of you familiar with these may know the rear flywheel is secured by a large nut which also contains a pilot bearing in the back side. Im repairing the trans and refurbishing much of the adjoining pieces hoping to bring some good life back to the machine. I have the rotovator parts ordered from UK, but the nut/bearing is not in their vocabulary.
Any suggestions as to where I can source this item would be great.
Thanks in advance.
Dan
:salute:
 

s100

Registered
Just ran across your post and saw you have no replies. I for one cannot visualize what you have going on there. I am guessing it is something unique to the Howard as most Wisconsin AEN's have a rope starting sheave on the end of the flywheel but I think the Howards start with a crank in the body of the machine. I know there are several Howard people on this site so maybe if you included a picture of the area in question you might get some useful replies.

Since the standard Wisconsin rope starting sheave and the flywheel retaining nut are incorporated into one piece, if you are missing the correct Howard nut etc. maybe you could find a Wisconsin sheave and use it to rope start the engine.
 
Top